[Aptitude-devel] weird aptitude behavior with "grub" package?

Sven Joachim svenjoac at gmx.de
Sat Sep 5 06:53:48 UTC 2009

On 2009-09-05 07:45 +0200, Miles Bader wrote:

> The newest version of the "grub" package is a dummy package which
> depends on "grub-pc", and is supposed to cause that pckage to replace
> the old "grub-legacy" package.
> On my system, currently "grub" and "grub-legacy" are installed;
> grub-legacy is marked "auto".
> However if I just do "U" to upgrade, aptitude marks _all_ of the grub
> packages to be uninstalled, and _doesn't_ mark grub-pc for installation.
> This seems very dangerous -- wouldn't it mean a simple upgrade causes
> the system to end up without any bootloader at all?!

Yes.  Although it would at least not make the system unbootable, because
the files in /boot/grub are not touched.

> (I _can_ install "grub-pc" explicitly, so there's no obvious conflict)

There is, grub-pc conflicts with grub.  I'll file a bug report on that


More information about the Aptitude-devel mailing list