[Aptitude-devel] aptitude 0.5.9rc2 released

Daniel Burrows dburrows at debian.org
Mon Sep 14 14:18:39 UTC 2009

On Mon, Sep 14, 2009 at 08:57:16AM +0200, Sven Joachim <svenjoac at gmx.de> was heard to say:
> On 2009-09-12 18:38 +0200, Daniel Burrows wrote:
> >   One thing I've noticed so far is that there seems to be some
> > flakiness in the dependency solver, particularly that it seems to miss
> > solutions that require removing packages (but only sometimes).  I
> > haven't had a chance to track this down yet.
> Maybe the libreadline-dev package gives a hint, aptitude needs some
> suasion to install it:

  That's correct: in response to a lot of complaints (e.g., #359171),
the resolver has been redesigned to be more conservative about trying
to remove packages.  But the situation I ran into was one where it
wasn't considering removals at all, even after I skipped past the first
few solutions.


More information about the Aptitude-devel mailing list