[Aptitude-devel] About status of aptitude-gtk -- proposal to at least remove it from "stable"

Manuel A. Fernandez Montecelo manuel.montezelo at gmail.com
Tue Mar 20 00:09:19 UTC 2012


Apart from random crashes that are reported quite often
[c1][c2][c3][c4][c5] despite the low popcon (~500):

[c1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=563319
[c2] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=572137
[c3] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=575956
[c4] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=513851
[c5] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=526899

...there are serious lack of functionality with aptitude-gtk, like
(almost all from the same person, but which I can confirm):

1) popcon and debtags tabs in package info being completely empty ([u1][u2])
2) failing to perform the most basic of operations [u3][u4]
3) lacking the power of aptitude-ncurses [u5] (according to the bug
report from a different person "However, as soon as I tried to use it,
I found it was just a hollow shell.". I never used aptitude-gtk much
in the past anyway)

[u1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=619762
[u2] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=619763

[u3] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=619765
[u4] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=619759

[u5] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=547415

The reporter of the majority of these reports, one year ago, goes on
to finally recommend [u6]:

  [u6] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=619767

 "aptitude-gtk is not well usable on my several fresh squeeze
  installations. Because this and important bugs filled against it,
  aptitude-gtk should IMO have smaller priority in
  /etc/alternatives/aptitude than far more mature and perfectly usable

Apart from agreeing with the bug report in the /etc/alternatives
thing, the general situation of aptitude-gtk will only improve if
there's somebody with the knowledge and will enough to bring
aptitude-gtk to an usable state.

I think that aptitude-gtk in the meantime does more harm than good,
kind of "damaging the reputation of the brand".  So at least I think
that it should be forbidden to enter stable, and maybe even testing,
until/unless it delivers acceptable quality (on part with, let's say,

I don't know why even was allowed to drop into stable for such a
sensitive/important package, since the last paragraph of the package
description is:

  "This package contains an EXPERIMENTAL version of aptitude
   that includes a GTK+-based graphical interface. It is INCOMPLETE
   and may not work properly. If you do not need a GUI or prefer a more
   stable interface, you can instead use the version of aptitude
   found in the package "aptitude".


More information about the Aptitude-devel mailing list