[Aptitude-devel] aptitude 0.6.6-1 available on mentors.d.n

Daniel Hartwig mandyke at gmail.com
Mon Mar 26 15:47:59 UTC 2012

On 26 March 2012 15:17, Sven Joachim <svenjoac at gmx.de> wrote:
> On 2012-03-26 04:54 +0200, Daniel Hartwig wrote:
>> It would be appreciated if people testing this version keep an eye on
>> the multi-arch changes.  There are still some noticable deficiencies
>> due to the internal model of APT, but most should agree the the
>> situation is a strong improvement.
> Have you tested aptitude with the apt version in experimental yet?  The
> apt version in unstable is next to unusable with multiarch due to bug
> #665727. :-(

Oh dear, thanks for pointing this out.  No sense uploading multiarch
support if broken underneath us :-/

Two weeks ago I performed some testing with aptitude built against
libapt-pkg and libept from exp. and it was working ok.  I had to
custom build libept to avoid #663201 (bad build-depends) which
prevents a sane package from using libept/exp.

I have taken care that the multi-arch code is compatible but not yet
thoroughly checked all the API changes which may impact aptitude.

Noone wants to waste time fixing apt/unstable that could better be
spent to finish 0.8.16, so I will check out the changelog and make
sure aptitude is ok with it and retarget this upload to experimental.

Now, if libept could be fixed in the meantime... or is this a non-issue?


More information about the Aptitude-devel mailing list