[Babel-users] Multi-Radio with Babel

Matthieu Boutier boutier at pps.univ-paris-diderot.fr
Wed Jan 8 12:57:34 UTC 2014


Hello,

> Before beginning the tests  in real life, i would like to know if anyone of you could make it work properly and share its configuration (my thoughts are about the need to use, or to not use, a bridge interface "br0") :
> - Bridge : What is the recommended configuration refering bridging : should i create a bridge (br0) for wlan0 and wlan1 or not ?

No ! Or babeld will not be able to use each interface, as it should.

> - IP Addresses :
>    -> must i assign a unique IP address do each wlan interface (or a unique to br0)
>    -> if i must assign two different IP addresses (one per wlan interface), must i assign an IP address in different or same subnet (192.168.1.0/28 and 192.168.2.0/28 OR both in 192.168.1.0/28) ?

For this purpose, we use one unique IP address for all interfaces.  For example, on omicron (openwrt) we use :
$ cat /etc/config/network
[…]
config interface 'wifi0'
	option ifname 'wlan0'
	option proto 'static'
	option ipaddr '192.168.4.39/32'
	list ip6addr '2001:41d0:1:f19f:e246:9aff:fe4e:912e/128'
	list ip6addr '2001:05c0:1505:6b00:e246:9aff:fe4e:912e/128'

config interface 'wifi1'
	option ifname 'wlan1'
	option proto 'static'
	option ipaddr '192.168.4.39/32'
        list ip6addr '2001:41d0:1:f19f:e246:9aff:fe4e:912e/128'  
        list ip6addr '2001:05c0:1505:6b00:e246:9aff:fe4e:912e/128'
[…]

Note there is two v6 addresses, but they are on both interfaces.

> - Babeld : as i could read in the docs, i should then start babeld with option "wlan0 wlan1"

Yes, or alternatively, put "interface wlan0" and "interface wlan1" in the config file.

> thanks a lot in advance for your help

You're welcome !

Matthieu

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/babel-users/attachments/20140108/4380cafa/attachment.html>


More information about the Babel-users mailing list