[Debconf-devel] Bug#550483: debconf: FTBFS in uptodate sid chroot

Helge Kreutzmann debian at helgefjell.de
Sat Oct 10 13:26:17 UTC 2009

Package: debconf
Version: 1.5.27
Severity: serious

Trying to build debconf in an uptodate chroot (x86) yields:
remaxp:/debuild/NEU-D/debconf# env LC_ALL=C debuild
 dpkg-buildpackage -rfakeroot -D -us -uc
dpkg-buildpackage: warning: using a gain-root-command while being root
dpkg-buildpackage: set CFLAGS to default value: -g -O2
dpkg-buildpackage: set CPPFLAGS to default value:
dpkg-buildpackage: set LDFLAGS to default value:
dpkg-buildpackage: set FFLAGS to default value: -g -O2
dpkg-buildpackage: set CXXFLAGS to default value: -g -O2
dpkg-buildpackage: source package debconf
dpkg-buildpackage: source version 1.5.27
dpkg-buildpackage: source changed by Colin Watson <cjwatson at debian.org>
dpkg-buildpackage: host architecture i386
dpkg-checkbuilddeps: Unmet build dependencies: libqt-perl
dpkg-buildpackage: warning: Build dependencies/conflicts unsatisfied; aborting.
dpkg-buildpackage: warning: (Use -d flag to override.)
debuild: fatal error at line 1324:
dpkg-buildpackage -rfakeroot -D -us -uc failed

remaxp:/debuild/NEU-D/debconf# env LC_ALL=C apt-get install libqt-perl
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libqt-perl: Depends: libsmokeqt1 (>= 4:3.5.10) but it is not installable
E: Broken packages

which is reported as #522580 (the bug title is misleading, the dependecy 
already left sid)

      Dr. Helge Kreutzmann                     debian at helgefjell.de
           Dipl.-Phys.                   http://www.helgefjell.de/debian.php
        64bit GNU powered                     gpg signed mail preferred
           Help keep free software "libre": http://www.ffii.de/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <http://lists.alioth.debian.org/pipermail/debconf-devel/attachments/20091010/3b6857f4/attachment.pgp>

More information about the Debconf-devel mailing list