[Debian-eeepc-devel] eee 900, linux 2.6.25, and card reader problem

Alexey Lebedeff binarin at binarin.ru
Sat Aug 23 20:16:40 UTC 2008

Don't found any mentions of this problem in wiki, so writing here.

After installing debian lenny on my eee, card reader was not working.

There was changes in 2.6.25 which was aimed to avoid some other
cardreader bugs, but also broken eee reader.

I applied fix from http://www.spinics.net/lists/linux-scsi/msg28197.html
to 2.6.25 kernel and all started working smoothly.

As i can see, this patch is also needed for 2.6.26 from unstable.

And this patch was finally accepted into the kernel 2 weeks ago:

More information about the Debian-eeepc-devel mailing list