[Debian-ha-maintainers] Error on installing libcluster-glue

Simon Horman horms at verge.net.au
Wed Mar 24 22:19:47 UTC 2010


On Wed, Mar 24, 2010 at 06:23:36PM +0100, Florian Haas wrote:
> On 03/24/2010 11:11 AM, Andreas Kurz wrote:
> > Hello all,
> > 
> > when trying to upgrade Heartbeat2 (apt-get install pacemaker heartbeat) on 
> > Lenny to recent Pacemaker + Heartbeat3 packages from  
> > http://people.debian.org/~madkiss/ha I get the following error:
> > 
> > ....
> > Unpacking libcluster-glue (from .../libcluster-
> > glue_1.0.3+hg2337-1~bpo50+1_amd64.deb) ...                                    
> > dpkg: error processing /var/cache/apt/archives/libcluster-
> > glue_1.0.3+hg2337-1~bpo50+1_amd64.deb (--unpack):                  
> >  trying to overwrite `/usr/lib/libstonith.so.1.0.0', which is also in package 
> > heartbeat
> > ....
> 
> Hrm. I wonder what would be the correct way of fixing this. Clearly this
> is a conflict from a file in the new libcluster-glue package with the
> same file in the old heartbeat package.
> 
> Simon, Frederik: do the Conflicts and Replaces fields presently in
> cluster-glue need to be moved to libcluster-glue?

I'm not entirely sure either. But I think that the following is needed
in order to conflict with the old heartbeat package.

diff -r 1f8847422e8e debian/control
--- a/debian/control	Fri Mar 12 12:42:13 2010 +0100
+++ b/debian/control	Thu Mar 25 09:18:38 2010 +1100
@@ -11,8 +11,8 @@
 Package: libcluster-glue
 Architecture: any
 Depends: ${shlibs:Depends}, ${misc:Depends}
-Replaces: cluster-glue (<= 1.0.3-2)
-Conflicts: cluster-glue (<= 1.0.3-2)
+Replaces: cluster-glue (<= 1.0.3-2), heartbeat (<= 2.99.2+sles11r9-5)
+Conflicts: cluster-glue (<= 1.0.3-2), heartbeat (<= 2.99.2+sles11r9-5)
 Description: The reusable cluster components for Linux HA (libraries)
  This package contains the libraries provided by the cluster
  glue component by the Linux-HA project; it offers various




More information about the Debian-ha-maintainers mailing list