[Debian-ha-maintainers] Bug#601807: heartbeat: Segfault while using a failover IPv6 address

Laurent Caron lcaron at LNCSA.FR
Fri Oct 29 20:54:55 UTC 2010

Package: heartbeat
Version: 2.1.3-6lenny4
Severity: grave
Justification: renders package unusable


Heartbeat doesn't seem to play nice with ipv6.

It segfaults while trying to add an IPv6 address.

-- System Information:
Debian Release: 5.0.6
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux (SMP w/8 CPU cores)
Locale: LANG=fr_FR at euro, LC_CTYPE=fr_FR at euro (charmap=ISO-8859-15) (ignored: LC_ALL set to fr_FR at euro)
Shell: /bin/sh linked to /bin/bash

Versions of packages heartbeat depends on:
ii  adduser             3.110                add and remove users and groups
ii  gawk                1:3.1.5.dfsg-4.1     GNU awk, a pattern scanning and pr
ii  iproute             20080725-2           networking and traffic control too
ii  iputils-ping        3:20071127-1+lenny1  Tools to test the reachability of 
ii  libbz2-1.0          1.0.5-1+lenny1       high-quality block-sorting file co
ii  libc6               2.7-18lenny4         GNU C Library: Shared libraries
ii  libcurl3            7.18.2-8lenny4       Multi-protocol file transfer libra
ii  libglib2.0-0        2.16.6-3             The GLib library of C routines
ii  libgnutls26         2.4.2-6+lenny2       the GNU TLS library - runtime libr
ii  libltdl3            1.5.26-4+lenny1      A system independent dlopen wrappe
ii  libncurses5         5.7+20081213-1       shared libraries for terminal hand
ii  libnet1               library for the construction and h
ii  libopenhpi2         2.12.0-1             OpenHPI libraries (runtime and sup
ii  libpam-runtime      1.0.1-7              Runtime support for the PAM librar
ii  libpam0g            1.0.1-7              Pluggable Authentication Modules l
ii  libsnmp15           5.4.1~dfsg-12        SNMP (Simple Network Management Pr
ii  libssl0.9.8         0.9.8g-15+lenny8     SSL shared libraries
ii  libuuid1            1.41.3-1             universally unique id library
ii  libwrap0            7.6.q-16             Wietse Venema's TCP wrappers libra
ii  libxml2             2.6.32.dfsg-5+lenny1 GNOME XML library
ii  libxml2-utils       2.6.32.dfsg-5+lenny1 XML utilities
ii  mawk                1.3.3-11.1           a pattern scanning and text proces
ii  psmisc              22.6-1               Utilities that use the proc filesy
ii  python              2.5.2-3              An interactive high-level object-o
ii  python-central      0.6.8                register and build utility for Pyt
ii  zlib1g              1:    compression library - runtime

Versions of packages heartbeat recommends:
ii  iptables                      1.4.2-6    administration tools for packet fi
ii  logrotate                     3.7.1-5    Log rotation utility
ii  syslog-ng [system-log-daemon] 2.0.9-4.1  Next generation logging daemon

heartbeat suggests no packages.

-- no debconf information

More information about the Debian-ha-maintainers mailing list