[Debian-ha-maintainers] Bug#639551: csync2 sqlite3 support?

Lars Ellenberg lars.ellenberg at linbit.com
Mon Aug 29 11:10:51 UTC 2011

On Sun, Aug 28, 2011 at 07:40:09AM +0200, Laszlo Boszormenyi wrote:
> Package: csync2
> Version: 1.34-2.2
> Severity: important
> Hi Norbert, Lars,
> As I see, the current csync2 package in Debian/Sid does not build with
> sqlite3. I intend to remove sqlite2 from the archives as it's
> unsupported since 2005. However it seems upstream is working on a new
> major upstream release (2.0) and it's a release-candidate by now. Also
> it seems to support sqlite3. Hereby I ask for an update of csync2 in
> Debian.

Upstream: http://git.linbit.com/csync2.git/
Has sqlite3 support, as well as support for psql, and mysql backends,
and a few other features.

It is in RC status since Last November, but due to lack of time,
we have not yet done a serious "regression test".

Even so, we successfully use it on a number of systems, and there have
not been any complaints on the csync2 list yet, either.

I suggest you go with current git.

I'm currently not aware of any issues, even though I suspect that there
will be some obscure (thus I still kept the "candidate") -- if you would
be more happy with an "official" 2.0, I can find some time this week
and tag it as such, as it is.

If you get any bug reports or other feedback,
contact me, and if the bug report is well written,
we should be able to deal with it promptly.

: Lars Ellenberg
: LINBIT | Your Way to High Availability
: DRBD/HA support and consulting http://www.linbit.com

More information about the Debian-ha-maintainers mailing list