[Debian-med-packaging] Bug#493341: Fix for 493341 (and a couple of other fixes you might want to apply)

peter green plugwash at p10link.net
Sat Aug 2 12:50:10 UTC 2008

tags 493341 +patch

add bioperl to the build-depends to fix this bug.

you might also want to add  libgd-gd2-perl to the build-depends to fix 
the following warning

         GD.pm does not seem to be installed.

         GD is reqired to produce "sequence logos" from
         information content matrices. If you need this
         functionality, please visit
         for information on obtaining and installing GD.

The package also FTBFS if built twice in a row because after a build the 
clean target prompts for user input. I this can be fixed by removing 
unpatch from the dependencies of the clean target and adding 
"debian/rules unpatch" to the end of the clean target.

note: while this bug was reported from a s390 buildlog it seems to be a 
general problem (it failed on every autobuiler that tried to build it). 
My testing was done on amd64.

More information about the Debian-med-packaging mailing list