[Debian-med-packaging] Bug#608394: Bug#608394: insighttoolkit: superfluous build dependency on libpoppler-dev

Mathieu Malaterre mathieu.malaterre at gmail.com
Thu Dec 30 21:26:34 UTC 2010

On Thu, Dec 30, 2010 at 10:21 PM, Steve M. Robbins <steve at sumost.ca> wrote:
> On Thu, Dec 30, 2010 at 03:36:10PM +0100, Pino Toscano wrote:
>> Package: insighttoolkit
>> Version: 3.18.0-5
>> Severity: minor
>> Hi,
>> insighttoolkit build depends on libpoppler-dev, but I cannot see anything using
>> Poppler (look for GlobalParams or PDFDoc); also a search in changelog
>> apparently gives no reasons for it.
> Sorry for the unuseful changelog.  From SVN, I found that it was added
> in July 2009 when we started using the system GDCM library.  I needed
> to add a whole lot of libraries at that time.
>> If this B-D is really not used, could you please remove it?
> I'll investigate again on the next upload.

I believe this was a bug in GDCM 2.0.14 where cmake would do
transitive linking and thus any libraries needed in GDCM to build
would be forward to any other tooolkit *using* GDCM.

If ITK still needs poppler then this is a bug in GDCM, because gdcm
should have no other dependencies other than itself.


More information about the Debian-med-packaging mailing list