[Debian-med-packaging] Bug#565004: Bug#565004: insighttoolkit: ftbfs with gcc-4.5

Charles Plessy plessy at debian.org
Wed Jan 13 04:22:34 UTC 2010

Le Wed, Jan 13, 2010 at 02:01:49AM -0200, Nelson A. de Oliveira a écrit :
> Hi!
> On Tue, Jan 12, 2010 at 11:04 PM, Matthias Klose <doko at debian.org> wrote:
> > /usr/include/c++/4.5/bits/stl_uninitialized.h: In function 'void std::__uninitialized_construct_range(_ForwardIterator, _ForwardIterator, _Tp&)':
> > /usr/include/c++/4.5/bits/stl_uninitialized.h:231: error: a function call cannot appear in a constant-expression
> > /usr/include/c++/4.5/bits/stl_uninitialized.h:231: error: template argument 1 is invalid
> > /usr/include/c++/4.5/bits/stl_uninitialized.h:232: error: invalid type in declaration before '(' token
> > /usr/include/c++/4.5/bits/stl_uninitialized.h:232: error: invalid use of qualified-name '::__ucr'
> This one seems to be a problem in gcc 4.5, right?

Hi Nelson !

this is explained at the top of the bug, and the severity has been accordingly
set to normal instead of serious.

[To Matthias:] Nevertheless, it would be useful for us to know a timeline for
GCC 4.5 to become the default compiler (thus making this bug RC). Is it before
or after the Squeeze release ? Please do not hesitate to answer this general
question on -devel.

Have a nice day,

Charles Plessy
Debian Med packaging team,
Tsurumi, Kanagawa, Japan

More information about the Debian-med-packaging mailing list