[Debian-med-packaging] Bug#646133: acedb: FTBS: /usr/bin/ld: cannot find -lcurses

Sven Joachim svenjoac at gmx.de
Fri Oct 21 16:53:29 UTC 2011

Package: acedb
Version: 4.9.39+dfsg.01-3
Severity: serious

>From my pbuilder log:

| gcc -g -o makeUserPasswd makeUserPasswd.o -L. -lfree -lmd5 -L/usr/X11R6/lib `../w3rdparty/libs-config glib-2.0 gtk+-2.0` -lm -lcurses -lreadline -lX11
| /usr/bin/ld: cannot find -lcurses
| collect2: ld returned 1 exit status
| make[2]: *** [makeUserPasswd] Error 1

Either add libncurses-dev to Build-Depends, or (preferably) patch the
upstream build system to not use -lcurses unnecessarily (the
buildd logs show a corresponding dpkg-shlibdeps warning).

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (101, 'experimental')
Architecture: i386 (x86_64)

Kernel: Linux 3.1.0-rc10-nouveau (SMP w/2 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

More information about the Debian-med-packaging mailing list