[Debian-med-packaging] Bug#663889: [Pkg-haskell-maintainers] Bug#664623: libghc-unixutils-dev is not installable

Joachim Breitner nomeata at debian.org
Mon Mar 19 14:26:02 UTC 2012

Version: 1.48.1-2+b1


as it happened I fixed this problem using a binNMU just one hour ago, it
should hit a mirror of your choice soon.

Am Montag, den 19.03.2012, 14:01 +0100 schrieb Andreas Tille:
> I have totally no knowledge of Haskell but when trying to fix #663889 I
> went into this problem.  My gut feeling after applying the patch
> suggested by Tim Booth which did not solved the problem was to try
> installing libghc-unixutils-dev which could possibly provide a System
> module but I even failed installing it.

I have doubts, unixutils is not a very standard library, so if qiime
used it, it would be documented somewhere. I looked at the code and came
up with this patch.


Joachim "nomeata" Breitner
Debian Developer
  nomeata at debian.org | ICQ# 74513189 | GPG-Keyid: 4743206C
  JID: nomeata at joachim-breitner.de | http://people.debian.org/~nomeata
-------------- next part --------------
Description: GHC 7.4.2 compatibility
 This patch changes the module imports so that it works without the haskell2012
 library, which is hidden with GHC 7.4.1 by default.
Author: Joachim Breitner <nomeata at debian.org>
Bug-Debian: http://bugs.debian.org/663889

--- qiime-1.3.0.orig/qiime/support_files/denoiser/FlowgramAlignment/FlowgramUtils.lhs
+++ qiime-1.3.0/qiime/support_files/denoiser/FlowgramAlignment/FlowgramUtils.lhs
@@ -1,6 +1,6 @@
 > module FlowgramUtils where
-> import Array
+> import Data.Array
 > import System.IO.Unsafe (unsafePerformIO)
 > type FlowSignalDistrib = Array (Int,Int) Float
--- qiime-1.3.0.orig/qiime/support_files/denoiser/FlowgramAlignment/FlowgramAli_4frame.lhs
+++ qiime-1.3.0/qiime/support_files/denoiser/FlowgramAlignment/FlowgramAli_4frame.lhs
@@ -1,13 +1,12 @@
 > module Main where
-> import Array
-> import List
+> import Data.Array
+> import Data.List
 > import FlowgramUtils
 > import ADPCombinators
-> import System(getArgs)
+> import System.Environment(getArgs)
 > import System.IO
-> import System.Exit(exitWith)
-> import System
+> import System.Exit(exitWith, ExitCode(..))
 > import Text.Printf(printf)
 The signature:
--- qiime-1.3.0.orig/qiime/support_files/denoiser/FlowgramAlignment/ADPCombinators.lhs
+++ qiime-1.3.0/qiime/support_files/denoiser/FlowgramAlignment/ADPCombinators.lhs
@@ -7,7 +7,7 @@ programming.
 > module ADPCombinators where
-> import Array
+> import Data.Array
 Lexical parsers
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
URL: <http://lists.alioth.debian.org/pipermail/debian-med-packaging/attachments/20120319/133697b4/attachment.pgp>

More information about the Debian-med-packaging mailing list