[Debian-med-packaging] Bug#671524: samtools depth caps coverage at 8000

Dominique Belhachemi domibel at debian.org
Fri May 4 20:15:27 UTC 2012

Package: samtools
Version: 0.1.18-1

samtools depth sets a cap of 8000 for coverage. It becomes an issue
when used to calculate depth for targeted sequencing applications.
Attached patch increases the threshold to 1 million.

Is this safe to apply?


Index: bam2depth.c
--- bam2depth.c	(revision 995)
+++ bam2depth.c	(working copy)
@@ -80,6 +80,7 @@

 	// the core multi-pileup loop
 	mplp = bam_mplp_init(n, read_bam, (void**)data); // initialization
+        bam_mplp_set_maxcnt(mplp,1000000); // set maxdepth to 1M
 	n_plp = calloc(n, sizeof(int)); // n_plp[i] is the number of
covering reads from the i-th BAM
 	plp = calloc(n, sizeof(void*)); // plp[i] points to the array of
covering reads (internal in mplp)
 	while (bam_mplp_auto(mplp, &tid, &pos, n_plp, plp) > 0) { // come to
the next covered position

Patch taken from here:

More information about the Debian-med-packaging mailing list