Bug#606857: vmtk: Depends on hard-coded Python version

Stefano Rivera stefano at rivera.za.net
Sun Dec 12 13:58:41 UTC 2010

Package: vmtk
Version: 0.9.0-1
Severity: normal
Tags: patch

Is there any reason that this package states "XS-Python-Version: 2.6" ?
XS-Python-Version is supposed to state the versions of python that the
source supports. Then pysupport will allow it to work with the
intersection of distro-supported and package-supported Python versions.

Does it not support 2.7?
Does it not support 2.5?

As far as I can tell, the upstream code-base supports >= 2.3 [0]

[0]: http://www.vmtk.org/Main/Installation

So I suggest:
> XS-Python-Version: >= 2.3



-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_ZA.UTF-8, LC_CTYPE=en_ZA.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

More information about the debian-science-maintainers mailing list