Bug#670423: gnuplot-x11: Wrong font path in debian/patches/05_default_gd_font.diff

Fabian Greffrath fabian at greffrath.com
Wed Apr 25 13:02:33 UTC 2012

Package: gnuplot-x11
Version: 4.6.0-5
Severity: minor


since the 05_default_gd_font.diff patch was introduced, the ttf-liberation
package was renamed into fonts-liberation and in this course the font path was
changed to /usr/share/fonts/truetype/liberation.

So far, noone noticed this discrepancy, probably because everybody uses the
libgd2-xpm library, which itself uses fontconfig and is thus able to find the
actual font based on the requested "pattern". However, when switching to
libgd2-noxpm, the following happens:

gnuplot> set term png
Terminal type set to 'png'
Could not find/open font when opening font "/usr/share/fonts/truetype/ttf-
liberation/LiberationSans-Regular.ttf", using internal non-scalable font

So, please adapt the correct font path in the patch and change gnuplot-nox's
recommends to fonts-liberation.

 - Fabian

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (901, 'testing'), (501, 'unstable'), (101, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 3.2.0-2-686-pae (SMP w/1 CPU core)
Locale: LANG=de_DE.utf8, LC_CTYPE=de_DE.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages gnuplot-x11 depends on:
ii  gnuplot-nox     4.6.0-5
ii  libc6           2.13-27
ii  libcairo2       1.10.2-7
ii  libedit2        2.11-20080614-3
ii  libgcc1         1:4.7.0-3
ii  libgd2-noxpm    2.0.36~rc1~dfsg-6+b1
ii  libglib2.0-0    2.32.0-4
ii  liblua5.1-0     5.1.5-1
ii  libpango1.0-0   1.30.0-1
ii  libqt4-network  4:4.7.4-3
ii  libqt4-svg      4:4.7.4-3
ii  libqtcore4      4:4.7.4-3
ii  libqtgui4       4:4.7.4-3
ii  libstdc++6      4.7.0-3
ii  libwxbase2.8-0
ii  libwxgtk2.8-0
ii  libx11-6        2:1.4.4-4

gnuplot-x11 recommends no packages.

gnuplot-x11 suggests no packages.

-- no debconf information

More information about the debian-science-maintainers mailing list