Bug#672770: gnuplot: Unable to upgrade gnuplot-nox or gnuplot-x11

Paul Menzel pm.debian at googlemail.com
Sun May 13 14:37:01 UTC 2012

Package: gnuplot
Version: 4.6.0-8
Severity: normal

Dear Debian community,

I am unable to upgrade the packages `gnuplot-nox` and `gnuplot-x11`.

        $ LANG=C aptitude -s install gnuplot-nox gnuplot-x11 # still 4.6.0-5
        The following packages will be upgraded: 
          gnuplot-nox{b} gnuplot-x11{b} 
        2 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
        Need to get 1988 kB of archives. After unpacking 689 kB will be used.
        The following packages have unmet dependencies:
         gnuplot-x11 : Conflicts: gnuplot-nox but 4.6.0-8 is to be installed.
         gnuplot-nox : Conflicts: gnuplot-x11 but 4.6.0-8 is to be installed.
        The following actions will resolve these dependencies:

             Remove the following packages:
        1)     gnuplot-nox                 

        Accept this solution? [Y/n/q/?] q
        Abandoning all efforts to resolve these dependencies.

This seems to be related to a change in 4.6.0-6.

        gnuplot (4.6.0-6) unstable; urgency=low

          [ Agustin Martin Domingo ]
          * [2c1a288] Change Replaces by Conflicts between different gnuplot-* flavors.


I do not know the reason for these conflicts, but somehow the upgrade
path got broken. I think Conflicts, Breaks and Replaces all have to be
set somehow to hint the package manager how to proceed.

I thought bug #671876 [1] would fix it, but I guess this issue is



[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=671876

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 3.2.0-2-686-pae (SMP w/2 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages gnuplot depends on:
ii  gnuplot-nox  4.6.0-5
ii  gnuplot-x11  4.6.0-5

gnuplot recommends no packages.

Versions of packages gnuplot suggests:
pn  gnuplot-doc  <none>

-- no debconf information
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
URL: <http://lists.alioth.debian.org/pipermail/debian-science-maintainers/attachments/20120513/317095de/attachment.pgp>

More information about the debian-science-maintainers mailing list