16:9 Twinpact support

Brendan Pike brendan at dbinformatics.com.au
Sun Sep 20 04:09:06 UTC 2009


Ben Hutchings wrote:
> On Sun, 2009-09-20 at 11:17 +0930, Brendan Pike wrote:
>   
>> Brendan Pike wrote:
>>     
>>> Can someone please guide me with some git basics, I'm new to git 
>>> (previously just a basic svn user).  I seem unable to clone the feed.  
>>> cli output below.
>>>
>>>
>>> bedlore at Studio:~/git_feeds$ sudo git clone 
>>> https://alioth.debian.org/anonscm/git/dvswitch/
>>> Initialized empty Git repository in 
>>> /home/bedlore/git_feeds/dvswitch/.git/
>>> fatal: https://alioth.debian.org/anonscm/git/dvswitch//info/refs 
>>> download error - server certificate verification failed. CAfile: 
>>> /etc/ssl/certs/ca-certificates.crt
>>>
>>> How do I get git to accept accept and import a certificate, I tried to 
>>> trick it by using svn initially and accepting thecertificate 
>>> permanently but this didn't fly. Some basic guidance needed please.
>>>       
>
> Sorry, I don't know; I am using ssh for read/write access so I hdn't
> actually tried the https route yet.
>
> I definitely have the right CA certificate installed (Debian servers use
> SPI as the certificate authority) but git still complains about the
> server certificate, so maybe there's a bug in git's SSL support.
>
> Your other options are git protocol and plain HTTP, which do not
> authenticate the server (though I do intend to sign tags in future so
> you will be able to verify them).
>
>   
>> Sorru for the dumb git newbie questions.  I've now managed to get it by 
>> using "git clone git://" instead.  Now I need a crash course in git, I 
>> was expecting it to be more or less the same for a basic end user, ie, 
>> svn export etc, but git doesn't apparently use export so I'm a bit 
>> confused.
>>     
>
> See <http://git-scm.org/course/svn.html> and also consider using the
> easygit front-end <http://www.gnome.org/~newren/eg/> which behaves more
> like svn.
>
> Use 'git archive' to export an archive.
>
>   
>> Also how to do I ensure I grab only 0.8 and not 0.9 in git?
>>     
>
> When you clone, by default you are creating a local repo (in the .git
> subdirectory) with copies of all the branches, with the 'master' (trunk)
> checked out.  You can then use 'git branch' to check out a different
> branch.
>
> Ben.
>   
Okay I think I made some progress. However I suspect there 'may' be a 
problem with the git feed itself?

The following command seems to export a branch to a directory fine.

git archive origin/0.8.x | (cd /home/bedlore/git_feeds/test/ && tar -xvf -)

however after running "cmake ." then make everything appears to have 
compiled correctly expect there is no dvswitch binary in src?

Also oddly there is information on 0.9 in the Changelog which I wouldn't 
expect to see in the 0.8 branch.

I am fast running out of time and have to leave in a couple of hours.  
Any chance someone can simply email me copy of the latest 0.8 brach with 
Ben's commits from last night please!

Thank you
Brendan



More information about the dvswitch-devel mailing list