[Nut-upsdev] Replace target.line and target.battery?

Niklas Edmundsson nikke at acc.umu.se
Mon Feb 13 12:50:14 UTC 2006

On Wed, 8 Feb 2006, Niklas Edmundsson wrote:

> I propose to replace the variables output.voltage.target.line and 
> output.voltage.target.battery with the variable output.voltage.nominal.
> The reasons for doing it:
> * Unify naming, the term "nominal" is used both in NUT and by UPS
>  makers for this.
> * Very few devices (none that I have seen) have a nominal output
>  voltage that differs when on battery/mains.
> * A single variable makes life easier when figuring out the nominal
>  voltage in upsimage and friends.
> The only reason I can find for not doing it is the fact that it might break 
> out-of-tree applications, but that's to be expected between major versions 
> anyway.

Noone has objected to this, so I'll whip up a patch that implements 
the change in docco and all related drivers. Since it's a rather 
simple change I don't expect too many things to break.

  Niklas Edmundsson, Admin @ {acc,hpc2n}.umu.se      |     nikke at acc.umu.se
  A day without sunshine is like night.

More information about the Nut-upsdev mailing list