[Nut-upsdev] libusb usage

Arjen de Korte nut+users at de-korte.org
Tue Dec 7 14:43:15 UTC 2010

Citeren Charles Lepple <clepple at gmail.com>:

> If you are trying to eliminate direct dependencies on the old  
> libusb-0.1 package, there is always the libusb-0.1-compat package. I  
> believe that FreeBSD 8+ has incorporated that into their libusb-1.0  
> API for the new USB stack, and aside from some changes in our  
> configuration scripts, it seems to work well at runtime.

Our existing configuration scripts work out of the box with  
libusb-compat-0.1 (at least on openSUSE 11.1+ this is the case). Other  
than installing it, no actions are needed for applications using it.  
The last release of openSUSE that shipped with native libusb-0.1 was  
11.1. At the same time they started shipping libusb-compat-0.1. Since  
openSUSE 11.2 came out, the native libusb-0.1 support was dropped from  
mainstream and is only available from the buildservice.

Best regards, Arjen
Please keep list traffic on the list (off-list replies will be rejected)

More information about the Nut-upsdev mailing list