[Nut-upsuser] No USB/HID UPS found

Peter Selinger selinger at mathstat.dal.ca
Mon May 8 19:52:17 UTC 2006

Charles Lepple wrote:
> On 5/8/06, Vladimir Botka <vlado at botka.homeunix.org> wrote:
> > Hi Peter,
> >
> > in FreeBSD usb driver is attached to USB controller. During the "bus
> > enumeration" "device generic USB driver" is attached (uhid in our case).
> But if you don't enable the uhid driver in the kernel configuration
> file, a ugen device should be attached, and that is what libusb can
> work with.
> > If there is no known working FreeBSD installation I expect that we will
> > have to do some lower level debuging which will be more time consuming.
> I can't remember whether someone got newhidups or libhid working in
> *BSD, but they both use very similar routines to talk to libusb.

Similar problems were reported by Matt Staroscik on 5 Feb 2006
[nut-upsuser]. Thierry Thomas suggested a possible solution on the
list, but I don't know if this worked. 

Nevil Thatcher reported some trouble using newhidups on netBSD, see
posts to [nut-upsuser] ca. 28 Feb 2006. However, he reported having
fixed the problem on Mar 3. This involved fixing a bug in libusb. 

FreeBSD and libusb were discussed with Stewart Morgan on [nut-upsdev],
ca. 22 Sep 2005. He got it to work on Sep 27. 


I hope some of these old posts will lead you in the right direction.
Please report to the list of you figure out the problem / get anything
to work. -- Peter

More information about the Nut-upsuser mailing list