[Nut-upsuser] Can't get 'load.off' to turn off power to the PC: CyberPower 1200AVR

Mark E. Hansen meh at Winfirst.Com
Tue Sep 18 16:10:14 UTC 2007

On 09/18/07 06:48, Arjen de Korte wrote:
>>>> Alternatively, you might use upsrw and experiment with the value of
>>>> 'ups.delay.shutdown', which changes the same value in the UPS as the
>>>> 'load.off' command will. Unfortunately, it doesn't have a
>>>> 'ups.delay.restart', so you will need to press the power button to
>>>> switch the output back on again.
>>> Well, using upsrw to set ups.delay.shutdown to various values appears to
>>> accept the value, but no change is made to the actual value.
>> See above.
> Never mind that remark. Changing variables in nut-2.2.0 is broken for
> subdrivers that define multiple HID paths for the same NUT variable. It
> will only use the first HID path it finds, whether or not it is supported
> on the connected UPS. Since the apc-hid.c subdriver only has one mapping
> for 'battery.charge.low' this is OK, but it has no less than three for
> 'ups.delay.restart' and the one you need is the third.
> So forget about changing 'ups.delay.start', it won't work with nut-2.2.0
> (the development version should work however).
> Best regards, Arjen

Thanks for the help in getting the current development sources (to Charles
Lepple as well). I've downloaded and configured/installed nut-2.3.0-r1114.

However, I don't see any difference in how the setting of some variables
appears to be ignored.

For example, I used upsrw to view the variables available on my UPS and
see that this list includes battery.charge.low, which is set to 10. When
I set this to another value, an entry is written to /var/log/messages which
indicates that the value was successfully set, but the next upsrw run shows
that the value is still 10.

I tried many different values, 20, 50, 90, 25, etc., but all acted the same

I tried setting battery.runtime.low, which is the number of seconds of battery
runtime left when the UPS switches to LB, in seconds, but was not able to set
this above 600. When looking at the current status of the UPS, I see that the
existing runtime is 4702, so 600 seconds is about 13%.

What I really want to be able to do is get the UPS to decide to shut down the
PC when it is only a few minutes into the power failure. I know the UPS must
be able to support this because I can do this using the Windows-based
configuration tool (I have the exact UPS running on a Windows/2000 machine as

Perhaps there's just some magic in setting these values which I've not yet

Thanks again for any help.

More information about the Nut-upsuser mailing list