[Nut-upsuser] Masterguard A-19 3000

Carlos Rodrigues carlos.efr at mail.telepac.pt
Thu Sep 27 21:34:18 UTC 2007

On 9/27/07, Stefan Teubel <synchv at googlemail.com> wrote:
> I am trying to get this UPS talking with NUT (2.2.0) under Fedora
> 7/CentOS5.
> I have searched the mailing list and found some infos:
> http://lists.alioth.debian.org/pipermail/nut-upsdev/2007-February/001799.html but I'm not really sure how that helps me. USB would be cool but I don't really need that, it just has to work.
> I have also found a document that shows the pinout of the com port (page
> 8) there:
> http://www.watfordcontrol.co.th/products/UPS/series_ae1/Catalog_A-19_A_E_engl(1999).pdf
> My question is, do I have to swap the TXD and RXD pins to get it
> working?
> I have tried to add the USB device address into the ups.conf and run the
> driver config tool thing. After a while it says:
> tcgetattr(/proc/bus/usb/004/002): Inappropriate ioctl for device
> After that I have tried the serial port, with a 1:1 cable, which didn't
> worked as well.

What driver are you using? You can try the "masterguard" driver, or "megatec".

Carlos Rodrigues

More information about the Nut-upsuser mailing list