[Nut-upsuser] 2.2.2-pre2 64 bit rpm tested on openSUSE 10.3

Roger Price rprice at cs.uml.edu
Tue Apr 22 12:10:28 UTC 2008

On Tue, 22 Apr 2008, Arnaud Quette wrote:

> right. the API used is an old one, to have a wide platform support spectrum.
> You'll find a 3.0.7 archive here:
> http://opensource.mgeops.com/stable/sources/projects/psp/
> - Retrieve the .bz2
> - extract it, and get into the dir
> - call configure a first time to generate packaging/mgeops-psp-suse.spec
> - then /packaging/mgeops-psp-suse.spec to your SPEC dir, and the .bz2
> to your SOURCES dir
> - then issue an "rpmbuild -ba .../mgeops-psp-suse.spec"

All went well until I typed the command

   script -c "rpmbuild -ba /usr/src/packages/SPECS/mgeops-psp-suse.spec" 

which produced the message 

   ../../libtool: line 1311: g++: command not found
   make[4]: *** [tray-icon.lo] Error 1

I loaded g++ which had not been asked for; it requires package 
gcc42-c++.  The build then went much further, ending in

/usr/lib64/libupsclient.so: undefined reference to `select_read'
/usr/lib64/libupsclient.so: undefined reference to `select_write'
collect2: ld returned 1 exit status
make[3]: *** [psp] Error 1
make[3]: Leaving directory `/usr/src/packages/BUILD/mgeops-psp-3.0.7/src'

See http://rogerprice.org/mgeops-psp-3.0.7/rpmbuild.log for the gory 

Best Regards,

More information about the Nut-upsuser mailing list