[Openstack-devel] Bug#669836: openstack-dashboard-apache: transition towards Apache 2.4

arno at debian.org arno at debian.org
Sat Apr 21 12:07:59 UTC 2012

Package: openstack-dashboard-apache
Severity: important
User: debian-apache at lists.debian.org
Usertags: apache24webapptransition

Dear maintainer,

your package openstack-dashboard-apache is a web application which supports the Apache2
web server. We're upgrading Apache to the new upstream version 2.4 [1]
(tracked as transition bug #661958). This requires some changes in your
package about how to interface to our package. You can test your package
against our package available in experimental [2] which is soon to be
uploaded to Sid. Please note, chances are that for the time being, third
party modules (e.g. mod_php, mod_perl and such) are not yet available in
a version capable to run with the Apache 2.4 web server. You can use
their (Fast-)CGI counter parts, e.g. php5-fpm to test your packages. You
can see an up to date state of modules being in the transition to
Apache2 2.4 at [3]. We have written packaging guidelines for our reverse
dependencies [4]. Please read this document carefully, it should be able
to answer most of your questions. Do also look at dh_apache2 (available
through  the dh-apache2 package) which can simplify shipping of Apache2
configuration files. 

In short, we want to highlight these changes you need to be aware of:

* Do NOT declare a strong relation against apache2.2-common (or
 apache2-common as its natural successor). Instead recommend "apache2 |
 httpd" in your package relationships. 

* Do NOT install any files to /etc/apache2/conf.d/. This directory is
 obsolete. Its successor is /etc/apache2/conf-available/ which can be
 interfaced through a2enconf/a2disconf

* Do NOT call a2enconf/a2disconf in your maintainer scripts. Use our
 apache2-maintscript-helper [4] instead. This is required to get a
 uniform and stateful handling of all web applications interfacing with

* Please use the new authentication and authorization directives of
 Apache 2.4 [6]. While the old style directives are in principle still
 supported using mod_access_compat, mixing old and new style directives
 can cause problems. Moreover, the compatibility mode may be removed in
 a future release.

You can look at our Apache 2.4 packaging hints [7] for hands-on

[1] https://lists.debian.org/debian-devel-announce/2012/03/msg00013.html
[2] http://packages.debian.org/search?keywords=apache2&searchon=sourcenames&exact=1&suite=all&section=all
[3] http://bugs.debian.org/cgi-bin/pkgreport.cgi?tag=apache24transition;users=debian-apache@lists.debian.org
[4] http://anonscm.debian.org/gitweb/?p=pkg-apache/apache2.git;a=blob;f=debian/PACKAGING;hb=next
[5] http://httpd.apache.org/docs/2.4/developer/new_api_2_4.html
[6] http://httpd.apache.org/docs/2.4/upgrading.html#run-time
[7] http://wiki.debian.org/Apache/PackagingFor24

More information about the Openstack-devel mailing list