[Parted-maintainers] Bug#604134: ppc: after debian installation MacOS 9.2 won't recognize, disk anymore

Mathias Wittau wittau at lnxnt.org
Mon Jan 17 01:38:49 UTC 2011

Dear Sebastian Schroeer!

Your workaround is usable - at least partially. In general it is still
possible to have a bootable Debian beside a bootable MacOS 9 at the same
disk, as long as the Hard Disk is smaller than 128 GB. The last 3 days I
did 8 or 9 complete installations of MacOS 9 AND Debian, so let me report
what happened.

>  >> the Linux partition was first on the
>  >> disk, that's what the d-i manual recommends
> Which manual do you actually refer to? Do you refer to the Debian manual
> for PowerPC installations?

I was referring to the "Debian GNU/Linux – Installationsanleitung"

As I already knew the tip with restarting, after Debian installation, with
the MacOS CD and using "update the driver" ("Treiber aktualisieren") from
within drive setup ("Laufwerke konfigurieren") from earlier debian list
postings (see above:
http://lists.debian.org/debian-powerpc/2008/05/msg00047.html ), I began by
repartitioning the entire HD, and putting the Linux partitons at the end
of the HD like you suggested. Who knows maybe the partitions at the end
would have worked, ... but they didn't. I tried manualy partitioning from
within the Debian installer, and also automatically partitioning of the
"biggest free space".

When I did the automatically partitioning at the end of the HD I
recognised that Debian installer reports the entire HD as valid - a 250GB
Seagate disk - while some G4 computers, like mine, have only controllers
for 128GB onboard, what is always reported correctly by MacOSs "drive
setup". But I could use, and even start to install at entire 250 GB with
Debian installer.

So I tried to repartition the drive with "drive setup" by doing 3
partitions. A small one at the end (of the 128 GB), and having 80GB for
Debian before that last small one, as I thought maybe debian will only use
that 80GB inside the part of the HD which is usable by the controller.

After every repartitioning -> installing MacOS 9 -> installing Debian ->
I used a MacOS 9.2.2 CD, and as it didn't work, the original MacOS 9.1 CD
that belongs to the machine, for trying if I can update the drivers. But
it never worked.

I followed the idea that the problem is the "too big HD", and tried
repartitioning the HD from within MacOS, with all partitions that Debian
will need. A small one for yaboot, a big one for "/" and a Swap partition.
Doing this, the debian installer should have only changed the filesystems
but not changed the partitioning itselve.

But also with the disc partitioned by MacOS and not by the Debian
installer, I was not able to use or boot my MacOS 9! I was also not able
to use the drive setup for updating the driver. That is really strange, as
the partition table was not touched by Debian, only the filesystems at
some partitions, ...

So I finally switched to another 80GB HardDisk, used "drive setup" for
creating 2 partitions. One 30 GB HFS+ and one 50 GB "undefined". Rebooted
into Debian installer from CD (the one I used at my first try -> see the
first report here at #604134) and used atomatically partitioning of the
greatest free space, as I did several times before with the other HD.
After installing Debian, I changed the yaboot.conf and added macos (like
also done many times before), used "ybin" and rebooted with the MacOS
9.2.2 CD.
It was immediatly possible to use drive setup, and update the driver. Now
I have a working MacOS 9/ Debian dualboot system.

Later I tried to veryfy everything, but my old Maxtor 20GB HD seems to be
broken. I could not install Debian at all, and I have no further empty HD.
So I am not absolutely sure, but belive the following (also because many
other people reported to use MacOS 9 successfully beside Debian):

-) The bug I reported only occures if the physical size of the disc is
bigger than the maximum possible size that the controller, built in to the
Mac, can handle. Only early G4s are limited to 128 GB. Later G4s even
supported 48-Bit-LBA at the onboard IDE controller.

-) There is no dataloss under circumstances that the disk fits to the
maxiumum possible size, usable by the built in controller (128GB at early

-) If the disk is bigger than the size the controller can handle, there is
recently no way to correctly use it. You would need to do a manually
partitioning to the maximum of 128 GB (at early G4s) and you will not be
able to use MacOS 9 and Debian at the same disk - means you will loose
your MacOS 9 installation and never be possible to restart it again, even
when access to the data in general is possible through Debian.

-) You need to update the driver in every case from the MacOS CD after
Debian installation, to be able to reboot into MacOS 9 (or 8.6) again, but
this workaround only works if the disc is smaller than 128 GB (if you use
the onboard controller of the early G4s).

I would suggest the following:

-) write a huge warning into the installation manuals
-) trying to fix the problem when using bigger disks at the original built
in controllers (but beware, as recent Terrabyte disks are no problems
throught PCI cards, and seem to be used often at G4s)
-) downgrade the bug if needed, as it only affects early G4 Macs with
upgraded HDs bigger than 128 GB which do not use the availaible space over
128 GB. A case that might be rarely, as users normally use addon cards for
using bigger SATA or IDE disks.

kind regards

Mathias Wittau

More information about the Parted-maintainers mailing list