Bug#539301: Pbuilder failed to create chroot for Sid in Lenny

Kartik Mistry kartik at debian.org
Thu Jul 30 14:25:27 UTC 2009

Package: pbuilder
Version: 0.181
Severity: important

When trying to run `pbuilder --create` in Lenny, it fails to create chroot with
following errors..

W: /home/kartik/.pbuilderrc does not exist
Distribution is sid.
Building the build environment
 -> running cdebootstrap
P: Retrieving Release
P: Retrieving Release.gpg
P: Validating Release
I: Good signature from "Debian Archive Automatic Signing Key (5.0/lenny) <ftpmaster at debian.org>"
P: Parsing Release
P: Retrieving Packages.gz
P: Validating Packages.gz
P: Parsing Packages
P: Deconfiguring helper cdebootstrap-helper-apt
P: Deconfiguring helper cdebootstrap-helper-makedev
P: Writing apt sources.list
P: Writing hosts
P: Writing resolv.conf
 -> debootstrap finished
 -> copying local configuration
  -> Installing apt-lines
Refreshing the base.tgz 
 -> upgrading packages
 -> mounting /proc filesystem
 -> mounting /dev/pts filesystem
 -> policy-rc.d already exists
Get:1 http://ftp.debian.org sid Release.gpg [835B]
Get:2 http://ftp.debian.org sid Release [94.4kB]  
Get:3 http://ftp.debian.org sid/main Packages [6016kB]
Fetched 6111kB in 2min 39s (38.3kB/s)                                                                                                                                             
Reading package lists... Done
dpkg: warning: ignoring request to remove lilo which isn't installed.
Obtaining the cached apt archive contents
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
build-essential is already the newest version.
dpkg-dev is already the newest version.
apt is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  aptitude: Depends: libapt-pkg-libc6.9-6-4.7 but it is not installable
            Depends: libept0 (>= 0.5.26+b1) but it is not going to be installed
E: Broken packages
 -> Aborting with an error
 -> unmounting dev/pts filesystem
 -> unmounting proc filesystem
 -> cleaning the build env 
    -> removing directory /var/cache/pbuilder/build//11827 and its subdirectories

-- System Information:
Debian Release: 5.0.2
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.26-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_IN, LC_CTYPE=en_IN (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages pbuilder depends on:
ii  cdebootstrap                  0.5.4      Bootstrap a Debian system
ii  coreutils                     6.10-6     The GNU core utilities
ii  debconf [debconf-2.0]         1.5.24     Debian configuration management sy
ii  debianutils                   2.30       Miscellaneous utilities specific t
ii  gcc                           4:4.3.2-2  The GNU C compiler
ii  wget                          1.11.4-2   retrieves files from the web

Versions of packages pbuilder recommends:
ii  cowdancer                  0.47          Copy-on-write directory tree utili
ii  devscripts                 2.10.35lenny3 scripts to make the life of a Debi
ii  fakeroot                   1.11          Gives a fake root environment
ii  sudo                       1.6.9p17-2    Provide limited super user privile

Versions of packages pbuilder suggests:
pn  pbuilder-uml                  <none>     (no description available)

-- debconf information:
  pbuilder/mirrorsite: http://ftp.debian.org/
  pbuilder/rewrite: false

More information about the Pbuilder-maint mailing list