Bug#531556: etch->lenny: conflicting libarchive-tar-perl was not automatically removed

Julien Cristau jcristau at debian.org
Tue Jun 2 11:21:13 UTC 2009

severity 531556 serious
reassign 531556 perl 5.10.0-19
retitle 531556 perl needs updated Replaces on libarchive-tar-perl

On Tue, Jun  2, 2009 at 12:20:44 +0200, Toni Mueller wrote:

> when I upgraded one of my Etch machines to Lenny, the new Perl 5.10 could not
> be installed because it conflicted with libarchive-tar-perl (version
> 1.38-3~etch1) which I had installed. As a consequence, all sorts of package
> managing scripts (debsums etc.pp.) broke, and nothing moved. I was able to
> manuall delete the offending package using dpkg, and get things going again,
> but I don't know if that's within reach of the end user because, at
> that point, the system was mostly non-functional because about half of
> all my packages were not correctly installed.
The version of libarchive-tar-perl you had installed is not in etch,
yet.  An upgrade from plain etch would have worked.

Reassigning to perl to hopefully get an updated version in lenny when
the new libarchive-tar-perl gets into etch.


More information about the Perl-maintainers mailing list