Bug#531556: upgrade problem with the proposed libarchive-tar-perl Etch update

Toni Mueller support at oeko.net
Tue Jun 2 14:05:51 UTC 2009

Hi Niko,

On Tue, 02.06.2009 at 15:36:31 +0300, Niko Tyni <ntyni at debian.org> wrote:
> I see three options for a fix: 
> - update the lenny perl-modules Conflicts 

methinks that the by far easiest and cleanest solution would be to
update the perl or perl-modules package in Lenny.

> FWIW, I'd prefer having this fixed inside the libarchive-tar-perl etch
> update, but I can certainly prepare a lenny update for the perl package
> if that turns out to be necessary.

Since Archive::Tar is afaik already contained in Perl 5.10 via
upstream, there is imho no place for a libarchive-tar-perl package in
Lenny in the first place. Therefore, I don't understand why the
"Replace" clause has a version number. Just removing the version number
and conflicting with all libarchive-tar-perl packages therefore seems
to be the correct solution to me.

Kind regards,

More information about the Perl-maintainers mailing list