[Pkg-alsa-devel] Bug#515185: Bug#515185: libasound2: jackd fails to start in Realtime with 1.0.18-1

Elimar Riesebieter riesebie at lxtec.de
Fri Feb 20 18:18:36 UTC 2009

* Josep Andreu [090219 01:15 +0000]
> Hi

> Sorry but I was edit my /etc/security/limits.conf file years ago,
> now,  when I was the problem,  I also was try to edit the
> limits.conf and do user rigths, but no way, no group and no user
> rigths. (I was do what explain on the jackd documentation)
> libasound2               .16 and .17  versions    jackd  runs perfect with realtime privileges as audio user group or as single user.
> libasound2 .18 only runs with relatime as root. 
> as single user or audio user group jackd returns the foolowing
> error:
> can't load "/usr/lib/jack/jack_alsa.so": libasound.so.2: failed to
> map segment from shared object: Bad address.

Well, I've got some enlightment ;) 1.0.18 has a changed API. So jack
has to be build against libasound2.dev_1.0.18, which isn't the case
yet. Either rebuild jackd or wait until 1.0.19 is uploaded to sid.


  You cannot propel yourself forward by
  patting yourself on the back.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: Digital signature
Url : http://lists.alioth.debian.org/pipermail/pkg-alsa-devel/attachments/20090220/9503656c/attachment.pgp 

More information about the Pkg-alsa-devel mailing list