[Pkg-amule-devel] Bug#612962: Bug#612962: amule: Exits after a few minutes - probably due to severe memory leak

Sandro Tosi morph at debian.org
Sun Feb 13 23:00:15 UTC 2011

tags 612962 +confirmed

Hi Tony,
thanks for your report.

On Fri, Feb 11, 2011 at 22:06, Tony Houghton <h at realh.co.uk> wrote:
> Package: amule
> Version: 2.2.6+debian0-8
> Severity: important
> amule keeps quitting after a short time, often before it's reached the
> front of any download queues. I've tried runnning it from a terminal
> with ulimit -c unlimited but it just exits without any message. A few
> times I've noticed that it's eating masses of memory, causing severe
> swapping, so presumably it's exiting because it runs out of memory, but
> I'm not sure if that's the cause every time.

I can replicate it on one of my system (but not on another, weird)

> It seems to be triggered by trying to download several files at once
> (more than 10?). On one occasion I was experiencing the crashes with far
> fewer downloads but deleting the .aMule directory and restarting it made
> it work reliably.  But I've just tried deleting everything from .aMule
> except my partial downloads (currently 16 of them) and the instability
> is persisting.

There is a thread[1] on the upstream forum where the problem seems to
be related to the download limits, and to some bug in wx.

[1] http://forum.amule.org/index.php?topic=18543

Let's see how it goes, since the current solution seems to be in the
wx libs (so not even a amule bug).

Sandro Tosi (aka morph, morpheus, matrixhasu)
My website: http://matrixhasu.altervista.org/
Me at Debian: http://wiki.debian.org/SandroTosi

More information about the Pkg-amule-devel mailing list