[Pkg-bitcoin-commits] [libbitcoin] annotated tag v1.4 created (now f45f7d1)

Jonas Smedegaard dr at jones.dk
Tue Jun 17 14:57:26 UTC 2014


This is an automated email from the git hooks/post-receive script.

js pushed a change to annotated tag v1.4
in repository libbitcoin.

        at  f45f7d1   (tag)
   tagging  0cd3b041dc1e027eafbe9fcd72ca4645d339671f (commit)
  replaces  v1.0.10
 tagged by  Amir Taaki
        on  Sat Oct 12 00:00:38 2013 +0200

- Log -----------------------------------------------------------------
various fixes and improvements.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAABAgAGBQJSWHUNAAoJELvkzMTyLzm1Eb4QAI8kyYEMn2EAmvcnTxnx/1zD
2U6CeD/JbdZOAyEFHQiGARtLlppkGbGdagdpyHqL9hW3kGy2x/HYFZfNskh4Q4f6
n/3l3L6KmBJu41VbL4+3OhZsV5sc/PfPsHgnKCI8cO8ucvWXO6Q4DoYnobZ/uaFc
TDayunBXKEpdxXpsaxoBEfu9Pcxud8fa3UvbCGM//bEWAT2JtG7jQVm9uq2+oftw
PKiJMuf/YWE0SAHVBfY9onGAj/knzg2etsTGwA4fouWXLn0v31ITRqXXnUVuH9gY
VXEN//nbscwMWrp1btitZ5VjE6NWa7uKU7j129pCFxSGljLafZNtJPdB+mhJVKe2
CH++oSeq4Du9s/ZyKjB7HKmvUyNph+e2fBdDlIrabVqrw9mMxzNPsnY3d7O6HO4z
sgrx/5042OEJSDCj+QvWYD9eoa42REMbtGnOdeOkIx49Mc7wpjQKzptzNAswFUEi
mqVqrdS38557WYD4Fssex65qyblRcRknwoGWnpUedNeQfxGFT46TpfH1Z+phZ6c3
SX/8RW+vQvDsRHKU7Kb5gcN4Jtdn7Ms2sYtQZsBdSpGJ0T01qQSwU+gjZOdT1sQu
tVVbgwtJHGnvCkapx7UVXcb0nWYkooWExUMLexz+ahQ/ZlFw1JqIy/KziE8p+3CU
tQqBSCEga6W5qk3wqVxp
=bzU3
-----END PGP SIGNATURE-----

Amir Taaki (178):
      updated copyright year range.
      better build system checking for c++11 and adding to CXXFLAGS
      Added author to doxygen documentation.
      added author to sphinx documentation.
      commented out incomplete section of sphinx tutorial doc.
      Merge branch 'pcastell'
      proper deserializer making using of iterators rather than buffers.
      make end iterator for deserializer const, and add doxygen doc.
      load deserialized objects directly instead of creating a temporary buffer.
      add reasons why connect_input fail.
      write tx data to disk in native format.
      new style serializer using iterators.
      deleted bdb backend (obselete).
      switch to new serializer.
      purged protobuf. introduced new hash_digest_list, short_hash_list and block_header_type. database is storing block directly on disk with hashes now.
      remove misleading block comparison operator.
      tidy up sliced_detail a little (not much).
      updated doc for recent changes.
      update reorg test.
      assert that db ptr is good in db_open()
      bugfix - detail hash wasn't getting recomputed when we change the header.
      moved out of date unit tests.
      added beginning of test case suite.
      serial/deserial test.
      bugfix: properly return end iterator during block write serialize.
      additional test case for serialize unit test.
      cleanup of databases in leveldb backend.
      cleanup database batch code.
      address debits now stored in database.
      updated readme instructions.
      added blocks.sh starting script.
      made the instructions in blocks.sh file to a README file.
      updated readme for clarity.
      clarified readme further about where to add env variables to ~/.bashrc
      protobuf is no longer needed.
      replaced chain.fetch_outputs(), fetch_history(chain), fetch_output_values(chain) with chain.fetch_history()
      renamed serializer2 to serializer.
      bugfix: actually save inpoint in debit db (not previous outpoint)
      make protocol max_outbound configurable.
      query balances for an address.
      broadcast send handler
      balance tool actually calculates the balance now.
      exposed extract_input_address()
      subscriber_ptr typedef.
      got rid of checksum hashmap for fetch_history. queries are twice as fast.
      Now we use the technically correct term 'height' not 'depth'. End of an era.
      removed ancient bitcoin.sql schema.
      formatting of comments.
      height is now part of debit too.
      add depth to db_debit
      fetch_history returns a history structure.
      removed "typedef uint8_t byte" - just use uint8_t instead.
      moved data_stack to types.hpp (made it a public type).
      made a more friendly README.
      added "sudo ldconfig" line.
      download-blockchain.sh
      protocol: continue accepting nodes and perform handshake with them.
      channel_loader_module impl doesn't need to be publically exposed.
      be more forgiving on user provided data. this data is usually small in size and not performance critical.
      added human stop message to README.
      12 words mnemonic.
      pkg-config use -std=c++11 not -std=gnu++0x
      added url to pkgconfig file.
      ha ha wth satoshi?? generate_signature_hash() returns 1 and doesn't fail. http://permalink.gmane.org/gmane.comp.bitcoin.devel/1411
      add from_height optimisation.
      prettified serialize code by putting non-public stuff in impl/*.ipp files
      bugfix: typo in deserialize from last change.
      make tx deserialization less strict so that asserts aren't triggered by bad streams.
      tx deserial/serial tests
      use rsync for blockchain download.
      use rsync for blockchain download. display command.
      install some doc with libbitcoin.
      install download-blockchain.sh
      install download-blockchain.sh script.
      ability to std::cout << both output_point and input_point types.
      ability to compare 2 payment_address or use it as a key in a std::*map.
      made logging stuff in fullnode more intuitive.
      poll for "stop" command from user in fullnode.
      transaction_indexer class - makes an index of unconfirmed transactions. you can query this index using a Bitcoin address to see all related input and point points (returned as a txhash/index) with their relevant data (previous_output point for spends, and the Bitcoin value for outputs).
      build stuff for transaction_indexer (see previous commit).
      example of using transaction_indexer in fullnode example.
      add expiry of txs to indexer (thanks vitalik buterin for his input).
      bugfix: height was being dirtied before we used it. now have a separate dirty flag.
      provided composed operation: fetch_history() (gets history for an address from both the blockchain and transaction memory pool)
      added extra error checking to fetch_history() composed operation.
      typo: log_to_both should also output to file.
      use blockchain/ for database path not the less obvious 'database'
      implicitlly use std::bind in async_strand methods.
      bugfix: set_script should use the back value not the serialized script!
      Revert "bugfix: set_script should use the back value not the serialized script!"
      downgrade misleading 'error' messages.
      payment_type script::type() method can now detect input script types also.
      single extract() function for both input and output scripts.
      assert was checking size wrongly. script code has min 4 ops, not the input script itself.
      fix interger overflow in decode_hex when 0 size hex_str is used.
      added script::empty() method.
      add <atomic> to types.hpp header.
      use deserializer for parsing script.
      we now use the end_of_stream exception, not script::empty() for script deserial.
      enable all address types now for fetch_history()
      bugfix: decode_hex_digest should let decode_hex handle the string decoding stuff. just check the returned number of bytes is correct.
      bugfix thanks to shunyata <empty at cqdr.es>: if bignum value begins with 0x00, then SSL will skip to the first significant digit.
      bugfix: handle_confirm() doesn't get called when the circular buffer drops it out of memory so it wasn't getting deindexed in the transaction_indexer.
      split transaction pool store() method into validate() and store() methods.
      since transaction_pool expires items when they are forced out of the circular buffer, we don't need to expire transactions based on time in the indexer. we rely on the txpool implicit expiry instead and use less code.
      use compressed public keys.
      tx_pool::set_capacity() instead of passing param to constructor.
      show the failed input if validate_inputs_failed for tx pool validate.
      Revert "use compressed public keys."
      nicer address with less code.
      s/script/script_type/
      updated examples.
      split assert in indexer. makes tracking down bugs easier.
      input.input_script -> input.script, output.output_script -> output.script
      renamed async_strand::push() to randomly_queue() (name is more specific)
      bugfix: decode_hex throwing on invalid input.
      decode_hex: move scope of decoder inside main loop so it gets cleared.
      updated docstrings for async_strand.
      network::connect() timeout.
      stop channel if connection times out.
      logic error in timeout stuff.
      cancel disconnect timer when connected.
      stylistic changes:
      Merge branch 'spesmilo' into testnet
      logic error in testnet work_required() calculation.
      updated AUTHORS file.
      pblaa -> previous_blaa.
      comment for last_non_special_bits() [testnet func] in work_required()
      tidied up the repo.
      satoshi_to_btc
      mpk copy unit test.
      decode_hex_digest was using hash_digest_size. make it use actual HashType size.
      Added: (outputs, change) = select_outputs(unspent, min_value)
      not a fan of inheritance. prefer composition always.
      replace main std promise with a spinlock.
      stricter asserts in transaction indexer.
      when depth was renamed to height in libbitcoin, script opcode DEPTH inadvertently got renamed too.
      update script unit test.
      bugfix: optimisation with only reading bits field from block header was missing offset when deserializing bits field. result was that block version is substituted for bits field.
      tester to generate fake chains. customise the function step(..., n) to generate different chains for testing.
      move step(..., n) to a separate file to make it more obvious you're meant to customize that function.
      nicer scrjson unit test.
      fakechain adding txs (signature is not yet correct though)
      added missing warning output for validate_block::connect_input about spending immature coinbase.
      create a prefix of 100 blocks so coinbase tx is spendable (cannot spend immature coinbase txs).
      create a transaction.
      fix reorg testing tool.
      reorg test with double spending and everything.
      always deindex even if confirm error (like error::forced_removal)
      better debug logging for transaction pool stuff.
      bugfix: pass unconfirmed list to validate handler in txpool.
      fullnode: wait for session to stop.
      bugfix: zero out beginning bytes (before most significant digit) for deterministic wallet secret generation.
      sha256 minor tidying.
      increase credits/debits checksum to 8 bytes up from 4 to protect against collisions.
      just some debug logging to poller and indexer. might be useful in the future.
      pool/indexer detailed debug logging isn't needed in main code though.
      Merge branch 'master' of https://github.com/spesmilo/libbitcoin
      fixed problem with inconsistent debits db caused by 1JwSSubhmg6iPtRjtyqhUYYH7bZg3Lfy1T (for example). use a simpler strategy for loading debits instead of trying to be smart.
      swap order of outputs and spends for indexer to be consistent.
      fixed assert problem with tx getting indexed twice. see output below for debug logs.
      in fetch_history(chain, indexer, ...), height=0 => unconfirmed tx, height=max => non-existent.
      i like the debug logging. lets do more of this.
      safer transaction_pool - re-subscribe to blockchain reorgs right away so as not to miss any blocks.
      contextual logging using LOG_TXIDX and LOG_TXPOOL
      accept inconsistency and conflicts as a fact of life. try our best to resolve these.
      bugfix: output is found but spend already exists, so skip insertion instead of continuing to loop. also set found = true so assert doesn't trigger.
      update version macro in version.hpp
      time a section of code to find bottlenecks. not included in default dist.
      put decorator header in namespace.
      skip expensive checks when behind last checkpoint.
      updated checkpoints.
      double timed_section::elapsed()
      typo: missing brackets.
      no need for expensive duplicate check anymore. duplicate tx are no longer part of bitcoin.
      drop excessive logging. not helpful to users.
      missing Makefile.
      incorrect version number in version.hpp - corrected it.

Pablo Castellano (6):
      Update version in configure.ac too
      [doc] Fix some typos and add some links
      Added "clean" rule to examples/Makefile
      Remove BerkeleyDB from doc and INSTALL (--enable-bdb)
      Use AM_SILENT_RULES when building
      Update .gitignore

Robert Williamson (5):
      Added support for testnet, enable when running configure.
      Added tools folder, tools Makefile and bootstrap.cpp for importing blocks from a bootstrap.dat file.
      Merge branch 'master' of https://github.com/spesmilo/libbitcoin
      bootstrap.cpp changed break out of loop after reading the last block in the file. changed usleep(1000) to nanosleep. Even sleeping for just 1ns prevents the import from stalling.
      Merge branch 'master' of https://github.com/spesmilo/libbitcoin

Tom (1):
      Added AUR link to README

genjix (3):
      Merge pull request #15 from shunyata/master
      Merge pull request #19 from wingsuit/master
      Merge pull request #22 from PabloCastellano/master

shunyata (2):
      Bugfix regarding leading 00 bytes not being counted by BN_num_bytes
      Ignore some artifacts of checkinstall

-----------------------------------------------------------------------

No new revisions were added by this update.

-- 
Alioth's /usr/local/bin/git-commit-notice on /srv/git.debian.org/git/pkg-bitcoin/libbitcoin.git



More information about the Pkg-bitcoin-commits mailing list