[pkg-boost-devel] Boost and Python 2.4

Steve M. Robbins steve at sumost.ca
Thu Aug 16 19:28:56 UTC 2007

On Tue, Aug 14, 2007 at 12:50:34AM -0500, Steve M. Robbins wrote:

> Specifically: let's upload a 1.34.1 to unstable that is built
> with the standard gcc (4.1) and with the standard python (2.4).

OK, I finally managed to get it uploaded last night and it's busy
being built.

I thought that now would be a good time to send a general note
describing the current state of affairs and some long-term plans.
In particular:

* built with current gcc and python

* the Debian-specific short forms have changed
  * the -st variant has been removed
  * libfoo is now single-threaded, while libfoo-mt is multi-threaded
  * prior to version 1.34.0-1, bare libfoo used to be multi-threaded

* no pkgconfig support
  * will seek upstream support for this

* no python 2.5 support
  * will seek upstream support for this

If you can think of any other points to cover, let me know.  I propose
to send a message out tonight to maintainers of a package that
build-depends on boost and to debian-devel.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://lists.alioth.debian.org/pipermail/pkg-boost-devel/attachments/20070816/3a0f5f2b/attachment.pgp 

More information about the pkg-boost-devel mailing list