[pkg-boost-devel] problem with boost::mpi on sparc ?

Steve M. Robbins steve at sumost.ca
Sat Jun 5 18:07:49 UTC 2010

On Sat, Jun 05, 2010 at 07:28:22PM +0200, Christophe Prud'homme wrote:
> Hi
> is there a problem with Boost::MPI on sparc ?

I'm not aware of any problem.

> I got the message below with buildd on sparc fir the package life. There are
> no such problem on the other platforms. any ideas ?
> it looks like the lib is there but it is somewhat empty or something or
> missing some of the symbols
> boost::mpi::communicator::operator ompi_communicator_t*()

This looks like an Open MPI symbol.  However, Boost is built using
mpi-default-dev which, for Sparc, build-depends on lam4-dev so I
wouldn't have expected that symbol.

My first suspicion is somehow boost is built with one implementation
of MPI and life is built with another.  The build log confirms that
both openmpi and lam are pulled in as dependencies.

I know there is some talk of updating MPI, but I'm not sure what has
happened.  The PTS suggests that nothing has happened yet but 
you might want to check with the appropriate folks.

Let me know what you find out.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 190 bytes
Desc: Digital signature
URL: <http://lists.alioth.debian.org/pipermail/pkg-boost-devel/attachments/20100605/b6924386/attachment.pgp>

More information about the pkg-boost-devel mailing list