[pkg-boost-devel] Boost packages

Wichert Akkerman wichert at wiggy.net
Mon Feb 21 09:19:39 UTC 2011

On 2/21/11 05:48 , Steve M. Robbins wrote:
> I believe you'll find that GCCXMLParser tries to import
> ElementTree from three different places:
> try:
> 	# try to use internal elementtree
>      from xml.etree.cElementTree import ElementTree
> except ImportError:
>      # try to use cElementTree if avaiable
>      try:
>          from cElementTree import ElementTree
>      except ImportError:
>          # fall back to the normal elementtree
>          from elementtree.ElementTree import ElementTree
> On my system, python2.6 provides cElementTree.py:
>    python2.6: /usr/lib/python2.6/xml/etree/cElementTree.py
> and "pyste" works without error:
> Can you dig a bit further and let me know if I'm missing
> something?

It looks like my build isn't applying the patches, which would explain 
that error. I guess I broke that somewhere when trying to figure out how 
to build a package from svn.

Unfortunately pyste seems to choke badly on all my sourcecode, so I'm 
back to raw boost.python again.


More information about the pkg-boost-devel mailing list