Bug#478881: cl-acl-compat: Unspecified dependencies in package

Paul Metcalfe paul.metcalfe+debian at gmail.com
Thu May 1 15:51:42 UTC 2008

Package: cl-acl-compat
Version: 1.2.42+cvs.2007.05.07-dfsg-3
Severity: normal

cl-acl-compat ought to depend on cl-ppcre and cl-puri ---
(require :acl-compat) generates errors on sbcl.

[snip]@[snip] ~ $ sbcl
This is SBCL 1.0.15.debian, an implementation of ANSI Common Lisp.
More information about SBCL is available at <http://www.sbcl.org/>.

SBCL is free software, provided as is, with absolutely no warranty.
It is mostly in the public domain; some portions are provided under
BSD-style licenses.  See the CREDITS and COPYING files in the
distribution for more information.
* (require :acl-compat)

; loading system definition from
; /usr/lib/sbcl/sb-bsd-sockets/sb-bsd-sockets.asd into #<PACKAGE 
; registering #<SYSTEM SB-BSD-SOCKETS {10029C52E1}> as SB-BSD-SOCKETS
; registering #<SYSTEM SB-BSD-SOCKETS-TESTS {1002CA5361}> as

debugger invoked on a ASDF:MISSING-DEPENDENCY in thread #<THREAD 
"initial thread" {10027EAC41}>:
  component :CL-PPCRE not found, required by #<SYSTEM "acl-compat" 

Type HELP for debugger help, or (SB-EXT:QUIT) to exit from SBCL.

restarts (invokable by number or by possibly-abbreviated name):
  0: [ABORT] Exit debugger, returning to top level.


If I install cl-ppcre I get past the above error, but get a new one 
referring to cl-puri.  If I install cl-puri I can (require :acl-compat) 
without errors (AFAICS... I'm new to lisp).

-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (990, 'testing'), (300, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.24-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages cl-acl-compat depends on:
ii  common-lisp-controller        6.12       Common Lisp source and compiler ma

cl-acl-compat recommends no packages.

-- no debconf information

Further information:

sbcl is version 1:

and cl-ppcre is (obviously) not installed.


More information about the pkg-common-lisp-devel mailing list