[Pkg-cups-devel] cupsdDoSelect() failed - Function not implemented! in unstable cupsys 1.3.2-1 source package

Andreas G public at agehrke.com
Sat Sep 29 12:39:44 UTC 2007


Im not sure where to post my problem with installing the unstable cupsys 
1.3.2-1 source package on my Debian etch system. Please point me to the 
correct place if this isnt.

I have installed the package using:
apt-get -b source -t unstable cupsys
dpkg -i cupsys_1.3.2-1_i386.deb cupsys-bsd_1.3.2-1_i386.deb 
cupsys-client_1.3.2-1_i386.deb ...

I have the following cups packages installed:
neoiss:~/src# dpkg --list | grep cups 
ii  cupsys                           1.3.2-1    
ii  cupsys-bsd                       1.3.2-1  
ii  cupsys-client                    1.3.2-1
ii  cupsys-common                    1.3.2-1
ii  cupsys-dbg                       1.3.2-1
ii  libcupsimage2                    1.3.2-1 
ii  libcupsimage2-dev                1.3.2-1
ii  libcupsys2                       1.3.2-1
ii  libcupsys2-dev                   1.3.2-1

When I try to start cups with /etc/init.d/cupsys start, I get the 
following error in /var/log/cups/error_log:

Notice the "cupsdDoSelect() failed - Function not implemented!"

I [29/Sep/2007:15:08:43 +0200] Listening to (IPv4)
I [29/Sep/2007:15:08:43 +0200] Listening to /var/run/cups/cups.sock (Domain)
I [29/Sep/2007:15:08:43 +0200] Loaded configuration file 
I [29/Sep/2007:15:08:43 +0200] Using default TempDir of 
I [29/Sep/2007:15:08:43 +0200] Configured for up to 100 clients.
I [29/Sep/2007:15:08:43 +0200] Allowing up to 100 client connections per 
I [29/Sep/2007:15:08:43 +0200] Using policy "default" as the default!
I [29/Sep/2007:15:08:43 +0200] Full reload is required.
I [29/Sep/2007:15:08:43 +0200] Loaded MIME database from 
'/usr/share/cups/mime:/etc/cups': 36 types, 40 filters...
D [29/Sep/2007:15:08:43 +0200] Loading printer hp8150...
D [29/Sep/2007:15:08:43 +0200] Loading printer SharpMX2300N...
D [29/Sep/2007:15:08:43 +0200] Loading printer SharpMX2300N-bw...
D [29/Sep/2007:15:08:43 +0200] cupsdLoadRemoteCache: Not loading remote 
I [29/Sep/2007:15:08:43 +0200] Loading job cache file 
I [29/Sep/2007:15:08:43 +0200] Full reload complete.
I [29/Sep/2007:15:08:43 +0200] Cleaning out old temporary files in 
I [29/Sep/2007:15:08:43 +0200] Listening to on fd 2...
I [29/Sep/2007:15:08:43 +0200] Listening to /var/run/cups/cups.sock on 
fd 3...
I [29/Sep/2007:15:08:43 +0200] Resuming new connection processing...
X [29/Sep/2007:15:08:43 +0200] cupsdDoSelect() failed - Function not 
X [29/Sep/2007:15:08:43 +0200] Listeners[0] = 2
X [29/Sep/2007:15:08:43 +0200] Listeners[1] = 3
X [29/Sep/2007:15:08:43 +0200] BrowseSocket = -1
X [29/Sep/2007:15:08:43 +0200] CGIPipes[0] = 4
X [29/Sep/2007:15:08:43 +0200] printer[hp8150] 0
X [29/Sep/2007:15:08:43 +0200] printer[SharpMX2300N] 0
X [29/Sep/2007:15:08:43 +0200] printer[SharpMX2300N-bw] 0
E [29/Sep/2007:15:08:43 +0200] Scheduler shutting down due to program error.
D [29/Sep/2007:15:08:43 +0200] Saving remote.cache...
I [29/Sep/2007:15:08:43 +0200] Saving job cache file 

The stable binary package works just fine. What can cause the "Function 
not implemented!" error? Have I not installed cupsys properly? Am I 
missing a dependency?

Best regards,
Andreas Gehrke

More information about the Pkg-cups-devel mailing list