[Pkg-cups-devel] Bug#533186: Bug#533186: Bug not fixed, sorry

Till Kamppeter till.kamppeter at gmail.com
Thu Jun 18 17:50:59 UTC 2009

Martin-Éric Racine wrote:
> 2009/6/18 Josselin Mouette <joss at debian.org>:
>> Sorry, but cups depends on ghostscript-cups since it cannot work without
>> it.
> AFAIK only certain printers depend on ghostscript-cups.  Till can
> correct me if I'm wrong.

Yes, that's it. ghostscript-cups contains the pdftoraster, pstoraster, 
and pstopxl filters and PPDs for the pstopxl filter. It is only needed 
for CUPS Raster drivers. Therefore the CUPS Raster driver packages of 
Ubuntu (splix, cups-driver-gutenprint, hplip-cups) depend on this 
package. Also lsb depends on this package as the LSB standardizes the 
CUPS Raster driver interface. Debian should also make these packages 
require ghostscript-cups. The cups package only recommends 
ghostscript-cups, as it is not always needed, for example if PostScript 
printers or printers with built-in Ghostscript drivers are used, this 
package is not needed.

ghostscript-cups depends on cups, as CUPS must be running so that the 
PPD files of existing queues which use the pstopxl driver in this 
package get auto-updated when this package gets updated. In addtion, the 
files in ghostscript-cups only make sense together with CUPS.

> However, if we indeed depend upon ghostscript-cups because it was
> split from the main ghostscript package (a bad idea, IMHO),

The splitting is done to avoid ghostscript to depend on CUPS for the PPD 
updating. ghostscript is often used without CUPS, for screen display or 
for use with non-CUPS printing environments (LPRng, ...).

> then we'll
> need to upgrade the Depends and Recommends of both ghostscript-cups
> and cups.

The package dependencies which I have mentioned here are the ones 
implemented in Ubuntu Karmic. Please use the same ones in Debian.


More information about the Pkg-cups-devel mailing list