[Pkg-cups-devel] Bug#554579: Update of cups may fail if broken symlinks to ssl certificates exist

Andreas Büsching buesching at univention.de
Thu Nov 5 14:28:30 UTC 2009

Package: cups
Version: 1.3.8-1+lenny6
Severity: normal
Tags: patch

The update to cups version 1.3.8 may fail if broken symlinks to an ssl
certificate exist in the directory /etc/cups/ssl/. To ensure that the
symlinks to the snakeoil certificates are just created if there are no 
(broken) symlinks or any other certificate files yet the following patch
should be applied.

-- System Information:
Debian Release: 5.0.3
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-2-686 (SMP w/1 CPU core)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages cups depends on:
ii  adduser         3.110                    add and remove users and groups
ii  cups-common     1.3.8-1+lenny6           Common UNIX Printing System(tm) - 
ii  debconf [debcon 1.5.24                   Debian configuration management sy
ii  ghostscript     8.62.dfsg.1-3.2lenny1    The GPL Ghostscript PostScript/PDF
ii  libavahi-compat 0.6.23-3lenny1           Avahi Apple Bonjour compatibility 
ii  libc6           2.7-18                   GNU C Library: Shared libraries
ii  libcups2        1.3.8-1+lenny6           Common UNIX Printing System(tm) - 
ii  libcupsimage2   1.3.8-1+lenny6           Common UNIX Printing System(tm) - 
ii  libdbus-1-3     1.2.1-5+lenny1           simple interprocess messaging syst
ii  libgnutls26     2.4.2-6+lenny1           the GNU TLS library - runtime libr
ii  libkrb53        1.6.dfsg.4~beta1-5lenny1 MIT Kerberos runtime libraries
ii  libldap-2.4-2   2.4.11-1                 OpenLDAP libraries
ii  libpam0g        1.0.1-5+lenny1           Pluggable Authentication Modules l
ii  libpaper1       1.1.23+nmu1              library for handling paper charact
ii  libslp1         1.2.1-7.5                OpenSLP libraries
ii  lsb-base        3.2-20                   Linux Standard Base 3.2 init scrip
ii  perl-modules    5.10.0-19lenny2          Core Perl modules
ii  poppler-utils [ 0.8.7-2                  PDF utilitites (based on libpopple
ii  procps          1:3.2.7-11               /proc file system utilities
ii  ssl-cert        1.0.23                   simple debconf wrapper for OpenSSL

Versions of packages cups recommends:
pn  avahi-utils           <none>             (no description available)
ii  cups-client           1.3.8-1+lenny6     Common UNIX Printing System(tm) - 
ii  foomatic-filters      3.0.2-20080211-3.2 OpenPrinting printer support - fil
pn  smbclient             <none>             (no description available)

Versions of packages cups suggests:
ii  cups-bsd                1.3.8-1+lenny6   Common UNIX Printing System(tm) - 
ii  cups-driver-gutenprint  5.0.2-4          printer drivers for CUPS
pn  cups-pdf                <none>           (no description available)
ii  foomatic-db             20080211-2+nmu1  OpenPrinting printer support - dat
ii  foomatic-db-engine      3.0.2-20080211-1 OpenPrinting printer support - pro
ii  hplip                   2.8.6.b-4        HP Linux Printing and Imaging Syst
pn  xpdf-korean | xpdf-japa <none>           (no description available)

-- debconf information:
  cupsys/raw-print: true
  cupsys/backend: ipp, lpd, parallel, scsi, serial, socket, usb, snmp, dnssd

-------------- next part --------------
A non-text attachment was scrubbed...
Name: 030_dont_link_certs.patch
Type: text/x-diff
Size: 745 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/pkg-cups-devel/attachments/20091105/f6c48a4e/attachment.patch>

More information about the Pkg-cups-devel mailing list