[Pkg-cups-devel] Bug#566555: cupsaddsmb doesn't work when only cups drivers are available.

Kurt Roeckx kurt at roeckx.be
Sat Jan 23 22:07:02 UTC 2010

Package: cups-client
Version: 1.3.8-1+lenny7


I've been trying to install the cups windows drivers, and it
failed if I didn't add other drivers.

I had those files:
# ls -l /usr/share/cups/drivers/
-rw-r--r-- 1 root root      803 Apr 20  2006 cups6.inf
-rw-r--r-- 1 root root       72 Apr 20  2006 cups6.ini
-rw-r--r-- 1 root root    12568 Apr 20  2006 cupsps6.dll
-rw-r--r-- 1 root root    13672 Apr 20  2006 cupsui6.dll

And then I get the message:
No Windows printer drivers are installed

Looking at a strace, I see:
access("/usr/share/cups/drivers/pscript5.dll", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/share/cups/drivers/ADOBEPS4.DRV", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/share/cups/drivers/x64/pscript5.dll", F_OK) = -1 ENOENT (No such file or directory)
write(2, "No Windows printer drivers are in"..., 42No Windows printer drivers are installed!
) = 42

If I also added the following files from a windows XP it worked:
-rw-r--r-- 1 root root  728576 Apr 14  2008 ps5ui.dll
-rw-r--r-- 1 root root   16560 Jan 24  2007 pscript.hlp
-rw-r--r-- 1 root root 1060548 May 15  2007 pscript.ntf
-rw-r--r-- 1 root root  543232 Apr 14  2008 pscript5.dll

And it copied the cups drivers along with it.

I'm not sure if it's always required to have all those files.
I was under the impression that those 4 files were only needed
for the "microsoft postscript drivers".  Maybe the manpage can
be clarified?  It mentions that all 8 files in the cups section,
but it doesn't make sense to me.

PS: The manpage points to:

Which doesn't exist (anymore), instead it's
http://www.cups.org/software and you need to pick the "Windows
drivers".  And it's not obvious that the "source" actually
also contains the binaries.  (Or you can use the .rpm and
use alien.)


More information about the Pkg-cups-devel mailing list