Bug#663939: cyrus-common-2.2: please add Depends: db4.7-util, db5.1-util to the transitional package

Andreas Beckmann debian at abeckmann.de
Wed Mar 14 06:29:45 UTC 2012

Package: cyrus-common-2.2
Version: 2.4.13-1
Severity: normal
User: debian-qa at lists.debian.org
Usertags: piuparts


while doing upgrade tests squeeze -> wheezy with piuparts I noticed that
upgrading the cyrus packages failed because the database upgrade could
not be performed as dbX.Y-util were missing. Even after enabling
installation of Recommends (which is disabled by default in piuparts),
db4.7-util was missing.

Since the transitional cyrus-*-2.2 packages are most likely
installed/upgraded on old installations only that will need to perform a
database upgrade during the dist-upgrade step, adding Depends for the
extra tools needed in that case seems sensible to me.

What about adding an extra package like 'cyrus-upgrade' that depends on
the tools needed to perform a database upgrade? This could be installed
by the admin to ensure that there are always the right tools available
in case of a dist-upgrade.


More information about the Pkg-Cyrus-imapd-Debian-devel mailing list