Bug#388562: Perhaps solved the bug

Matthias Wamser mw+388562 at viacanale.de
Wed Dec 6 21:26:30 CET 2006


i had a smiliar problem, trying to authenticate with postfix over
saslauthd and pam to my ldap server. Since new libsasl2 (repectively
libsasl2-2) no more success. 

My system is a clean and uptodate etch running on debian etch vserver.

Surprisingly i could successful authenticate with "testsaslauthd".

Hm, authentication via postfix never reached the salsauthd (i could
see this with saslauthd in debug mode).

Finally i found a hint in
/usr/share/doc/libsasl2-2/README.configure-options :
libsasl2 is compiled with '--with-configdir=/etc/sasl:/usr/lib/sasl2'

Ok, i tried the following:

mkdir /etc/sasl
cp /etc/postfix/sasl/smtpd.conf /etc/sasl
/etc/init.d/postfix restart

eh voila, authentication works again :)

rm -rf /etc/postfix/sasl
/etc/init.d/postfix restart

It still works :))

So who is the bad boy/girl now? ;) The maintainers of sasl or the
postfix folks? Or the programmers? 

I had and have a lot of trouble with sasl and cyrus the last weeks. Another
example: In imapd.conf is an example line like this:

#tls_lmtp_cert_file: /etc/ssl/certs/cyrus-lmtp.pem

But "tls_lmtp_cert_file" is no longer correct.
Correct ist "lmtp_tls_cert_file". Just a little bit word scrabbling
but its annoying.

And i remember a similiar problem with auxprop sasl options in
imapd.conf. These small syntax changes from one day to another
can cost days of debugging. And you find no hints on this.
Documentation and examples use the wrong syntax (its not really
wrong, just for some (or newest) versions.

OK, i'll stop whinging. Make it better. And feel free to ask me
if you have unresolvable bugs in the future. I play a lot with
debians sasl/postfix/cyrus stuff but have not always the time
or the nerves to search for bugreports.

regards, matthias

@arno: please give me short feedback if this also works for you

More information about the Pkg-cyrus-sasl2-debian-devel mailing list