[pkg-db-devel] Bug#651692: Bug#651692: libdb5.1: needs Breaks on slapd

Ondřej Surý ondrej at sury.org
Sun Dec 11 13:29:54 UTC 2011

Thanks, I would never thought of testing PATCH release. I know that whole
berkeley db ecosystem is just one whole mess, but I guess it's the slapd
which needs to be fixed to test just for MAJOR + MINOR and ignore the
changes in patch number.


On Sun, Dec 11, 2011 at 13:42, Julien Cristau <jcristau at debian.org> wrote:
> Package: libdb5.1
> Version: 5.1.29-1
> Severity: serious
> Apparently openldap has some check that the build-time and run-time
> libdb versions match.  Which breaks when it's built against 5.1.25 and
> run against 5.1.29.  Filing this bug to avoid the new libdb making it to
> testing before slapd is fixed, and as a reminder that libdb5.1 should
> add Breaks on old slapd when #651333 is fixed.
> Cheers,
> Julien
> _______________________________________________
> pkg-db-devel mailing list
> pkg-db-devel at lists.alioth.debian.org
> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-db-devel

Ondřej Surý <ondrej at sury.org>

More information about the pkg-db-devel mailing list