[pkg-dhcp-devel] Bug#590186: dhcp3-relay: Uninstallable in unstable

Adam D. Barratt adam at adam-barratt.org.uk
Sat Jul 24 16:41:37 UTC 2010

Package: dhcp3-relay
Version: 4.1.1-P1-8
Severity: serious


dhcp3-relay depends on isc-dhcp-relay, which conflicts/replaces/provides
dhcp3-relay.  As a consequence, the package is not installable.

The changelog suggests this was fixed a while ago, but I guess -relay
was missed:

isc-dhcp (4.1.1-3) experimental; urgency=low
* debian/control: don't make the new packages conflict with the
     old/transitional packages

 -- Andrew Pollock <apollock at debian.org>  Sun, 06 Jun 2010 20:01:22 -0700

fwiw I spotted this during a test britney run to see whether the new
package was ready to migrate.  The ntp packages using the new hook
location already migrated to testing but are currently uninstallable
there for any users with dhcp3-client installed, due to the Breaks
applied in ntp.



More information about the pkg-dhcp-devel mailing list