[Pkg-directfb-devel] Bug#584617: Installation causes massive dependency problems for many other packages

Sven Joachim svenjoac at gmx.de
Sat Jun 5 07:26:25 UTC 2010

On 2010-06-05 09:00 +0200, Fathi Boudra wrote:

>> This is a problem of libdirectfb-1.2.9 which ought not to conflict with
>> libdirectfb-1.2-0.
> wrong, libdirectfb-1.2.9 should conflict against libdirectfb-1.2-0.
> There's conflicting files on armel architecture.

Did you look at the file conflicts and try to resolve them, e.g. by
moving the offending files?  And why do you declare a Conflicts:
libdirectfb-1.2-0 on *all* architectures rather than only on armel?

> We have done a directfb transition.
> Most of the packages should have been rebuilt against latest directfb
> (and depends on libdirectfb-1.2.9).
> Do you have some libxine2* packages, still depending on libdirectfb-1.2-0 ?

I don't, but Juhapekka is running a mixed stable/testing system where
your Conflicts: libdirectfb-1.2-0 makes partial upgrades impossible.
This is not how library transitions are supposed to be handled, please
make sure that the next libdirectfb-x.y.z packages do not share files
with libdirectfb-1.2-9.


More information about the Pkg-directfb-devel mailing list