Bug#429788: update-exim4.conf does not accept more complicated values

Norbert Preining preining at logic.at
Wed Jun 20 08:00:54 UTC 2007

Package: exim4
Version: 4.67-3
Severity: important

Hi all,

I have the following entry in my update-exim4.conf:
because I want to dynamically switch smarthosts, and fall back to our
server if necessary.

This worked till the latest upload when it suddenly broke,
update-exim4.conf now gives:

/usr/sbin/update-exim4.conf: non-ascii value ${lookup{*}lsearch{/etc/smarthost}{$value:}{}}our.local.smtp.server read from /etc/exim4/update-exim4.conf.conf, sanitizing to __lookup___lsearch_/etc/smarthost___value:____our.local.smtp.server

Putting the original line one-to-one into
/var/lib/exim4/config.autogenerated did work, mails were delivered.

The problem is in the check_ascii_pipe function in update-exim4.conf,
which only checks for 
	[^-0-9a-zA-Z\/\. at _~:; ]
but it should include also

Could you please explain what is the rational behind forbidding the
usage of exim4 functions in these variables?

Best wishes


-- Package-specific info:
Exim version 4.67 #1 built 18-Jun-2007 10:32:53
Copyright (c) University of Cambridge 2006
Berkeley DB: Sleepycat Software: Berkeley DB 4.3.29: (September  6, 2005)
Support for: crypteq iconv() IPv6 GnuTLS move_frozen_messages
Lookups: lsearch wildlsearch nwildlsearch iplsearch cdb dbm dbmnz dsearch nis nis0 passwd
Authenticators: cram_md5 plaintext
Routers: accept dnslookup ipliteral manualroute queryprogram redirect
Transports: appendfile/maildir/mailstore autoreply lmtp pipe smtp
Fixed never_users: 0
Size of off_t: 8

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.22-rc4 (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=en_US.ISO-8859-15, LC_CTYPE=en_US.ISO-8859-15 (charmap=ISO-8859-15)
Shell: /bin/sh linked to /bin/bash

Versions of packages exim4 depends on:
ii  debconf [debconf-2.0]         1.5.13     Debian configuration management sy
ii  exim4-base                    4.67-3     support files for all Exim MTA (v4
ii  exim4-daemon-light            4.67-3     lightweight Exim MTA (v4) daemon

exim4 recommends no packages.

-- debconf information:

More information about the Pkg-exim4-maintainers mailing list