Bug#621388: Still uses libdb4.8

Ondřej Surý ondrej at debian.org
Wed Apr 6 20:57:14 UTC 2011

Package: exim4
Version: 4.75-1
Severity: normal
User: pkg-db-devel at lists.alioth.debian.org
Usertags: db5.1

Your package currently still uses Berkeley DB version 4.8 (libdb4.8).

However, there is a newer Berkeley DB version in the archive (libdb5.1),
with a compatible API.  Berkeley DB version 4.8 will be eventually
removed from unstable in favor of version 5.1.

Please port your package to libdb5.1 as soon as possible.  In most cases
only change required is to update build depends from libdb4.8-dev
to libdb-dev, or just recompile the package.

More complicated scenarios:

- Package does check for DB_VERSION_MAJOR == 4 - this should be updated

- Configure checks - sometime there is a list of db-4.8 db-4.6 db-4.2, etc., this
  needs to be updated to just db (or db-5.1 db-5 db), or at least list the 'db'
  in the front

You can see example patch in cyrus-imapd-2.2:

- The packages which use Berkeley DB transactional mode need to upgrade
  the database files before the upgrade.  This is fairly straightforward
  and is well documented on the Berkeley DB website.  But you probably
  already know that because it's not the first Berkeley DB transition.

The example script can be found in the cyrus-imapd-2.4 (not yet released):

Ondřej Surý <ondrej at debian.org>

-- System Information:
Debian Release: squeeze/sid
  APT prefers maverick-updates
  APT policy: (500, 'maverick-updates'), (500, 'maverick-security'), (500, 'maverick-proposed'), (500, 'maverick-backports'), (500, 'maverick')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.35-28-generic (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

More information about the Pkg-exim4-maintainers mailing list