Bug#617812: exim4 security update trusted_configs silently ignored

Andreas Metzler ametzler at downhill.at.eu.org
Sat Mar 12 14:43:19 UTC 2011

On 2011-03-11 Ian Jackson <ijackson at chiark.greenend.org.uk> wrote:
> Package: exim4-base
> Version: 4.69-9+lenny4

> I just did the exim4 security update and it broke my mail system
> because of the new restrictions on the config file which can be used.

> I tried to fix this by adding an /etc/exim4/trusted_configs file as
> documented in the Debian changelog but this was not effective.

> I had to obtain the source and start debugging it, at which point I
> noticed the code which silently ignores the trusted_configs file if it
> has the "wrong" owner or mode.

Silenty, quietly? I get an error in paniclog. Please provide exact
steps on how to reproduce.

cu andreas

More information about the Pkg-exim4-maintainers mailing list